HY-TEK with Vista and Windows 7 & 8

All HY-TEK product CDs shipped in 2007 include the Windows Installer software required when installing HY-TEK products on a computer running Microsoft's Vista and Windows 7 & 8 Operation Systems. If you are having problems installing a HY-TEK product CD that you were shipped prior to 2007 and you are running Windows Vista or Windows 7 & 8, you will probably need to order a replacement CD. You can order a replacement CD from our Online Store if you have a current version of the software.